Локальный обновляемый репозиторий Ubuntu

В сети доступен локальный репозиторий Ubuntu. Обновление раз в 2-3 дня.

Доступ к ресурсу возможен по протоколам http, ftp.

Сведения по установке

Ubuntu - дружелюбный к пользователям дистрибутив, поэтому установить вы сможете без проблем самостоятельно. Если есть проблемы, их всегда можно обсудить на

Будьте внимательны!
При установке по сети очистите список зеркал, чтобы не тратить свой трафик, и добавьте в него единственное зеркало. Как - см. ниже.

Настройка на локальный репозиторий

Редактируем файл /etc/apt/sources.list с правами суперпользователя, например, текстовым редактором nano:

sudo nano /etc/apt/sources.list

Удаляем из файла всю дефолтную информацию (или комментируем строки с помощью символа #), в противном случае вы рискуете потратить трафик.

Добавляем локальное зеркало в список:

Precise(12.04)

deb http://ubuntu.snacho.ru/ precise main restricted universe multiverse
deb http://ubuntu.snacho.ru/ precise-security main restricted universe multiverse
deb http://ubuntu.snacho.ru/ precise-updates main restricted universe multiverse
deb http://ubuntu.snacho.ru/ precise-proposed main restricted universe multiverse
deb http://ubuntu.snacho.ru/ precise-backports main restricted universe multiverse

Oneiric(11.10)

deb http://ubuntu.snacho.ru/ oneiric main restricted universe multiverse
deb http://ubuntu.snacho.ru/ oneiric-security main restricted universe multiverse
deb http://ubuntu.snacho.ru/ oneiric-updates main restricted universe multiverse
deb http://ubuntu.snacho.ru/ oneiric-proposed main restricted universe multiverse
deb http://ubuntu.snacho.ru/ oneiric-backports main restricted universe multiverse

Natty(11.04)

deb http://ubuntu.snacho.ru/ natty main restricted universe multiverse
deb http://ubuntu.snacho.ru/ natty-security main restricted universe multiverse
deb http://ubuntu.snacho.ru/ natty-updates main restricted universe multiverse
deb http://ubuntu.snacho.ru/ natty-proposed main restricted universe multiverse
deb http://ubuntu.snacho.ru/ natty-backports main restricted universe multiverse

Lucid(10.04.1)

deb http://ubuntu.snacho.ru/ lucid main restricted universe multiverse
deb http://ubuntu.snacho.ru/ lucid-security main restricted universe multiverse
deb http://ubuntu.snacho.ru/ lucid-updates main restricted universe multiverse
deb http://ubuntu.snacho.ru/ lucid-proposed main restricted universe multiverse
deb http://ubuntu.snacho.ru/ lucid-backports main restricted universe multiverse

Для доступа по протоколу ftp достаточно заменить http на ftp.

Обновляем список пакетов и систему:

sudo aptitude update
sudo aptitude safe-upgrade

Установочные образы

Установочные образы для Ubuntu находятся в каталоге iso репозитория.

Скачать их можно по следующим ссылкам:

Precise(12.04)

Other

Если вы желаете сделать загрузочную флешку (с нее можно будет устанавливать систему), вы можете записать эти образы на флешк-накопитель с помощью утилиты Unetbootin. Windows версия этой программы для выложена здесь:


Wubi (Windows-based Ubuntu Installer) — официальный свободный установщик Ubuntu Linux, предназначенный для запуска в операционных системах семейства Windows, лицензированный под GPL. С помощью Wubi пользователи Windows могут устанавливать и удалять Ubuntu как обыкновенную Windows-программу.

С вопросами по зеркалу обращайтесь к Snacho

Обсуждение

Hawk, Y-m-d H:i

Зеркало работает с ubuntu 9.10 x64 beta, но не получается устанавливать программы из Ubuntu Software Center. При попытке установить какое-либо приложение выдает ошибку: «The action would require the installation of packages from not authenticated sources» http://picasaweb.google.ru/lh/photo/WuBSs6wGoyeb-RMOKgW_-Q?authkey=Gv1sRgCI2ihrqd8qrXOA&feat=directlink Как это побороть?

Alexander, Y-m-d H:i

попробуй обновить список пакетов с зеркала командой «aptitude update»(ну или просто в менеджере пакетов synaptic нажми Reload), возможно в это время я обновлял зеркало. если не поможет - отпиши, попробую ещё что-нить придумать.

skat, Y-m-d H:i

Мужики, я обновляю 9.04→9.10, но он просит чтоб репозитроий был доверенным источником. Для этого ключик нужен. Есть ли он для представленного локального репа? Предложение поставить сразу 9.10 не катит, ибо не ставится почему то( Машина асус еее 701, выкидывает при установке. Если вдруг кто то встречал, буду благодарен за помощь)

Snacho, Y-m-d H:i

попробуй один из 3 вариантов… 1) добавить в файл /etc/apt/apt.conf строку «APT::Get::AllowUnauthenticated 1;». если такого файла нет - создать, например командой «sudo gedit /etc/apt/apt.conf»
2) попробуй установить 9.10 netbook-remix, ссылки на него я добавил. если уже ставишь его, то не подходит.
3) добавить ключи. я к сожалению не могу точно сказать, как это сделать, т.к. у меня не возникает такой ошибки не возникает даже при отсутствии строки из первого решения.
но если при установке программ через «aptitude install» ты получаешь ошибку вида «GPG error: http://ubuntu.snacho.ru karmic Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY *тут число типа 2BFAFC26585DECB0*», то нужно выполнить пару команд:
gpg –keyserver subkeys.pgp.net –recv *здесь номер ключа из ошибки, например 2BFAFC26585DECB0*
gpg –export –armor *здесь номер ключа из ошибки, например 2BFAFC26585DECB0* | sudo apt-key add -
все без звездочек.

skat, Y-m-d H:i

попробую, спасибо)

skat, Y-m-d H:i

не, не получилось. Жалуется на то что не может проверить подлинность некоторых пакетов. Это через гуи. Консоль даже не жалуется не на что, просто после построения списка изменения молча откатывается назад. Netbookremix не хочу чего то, десктоп больше нравится.

Snacho, Y-m-d H:i

процитируй пожалуйста ошибку дословно. попробую поискать решение.

skat, Y-m-d H:i

Это я к тому, что ошибку с номером gpg не дает. И гугл не помощник(

skat, Y-m-d H:i

Да, еще. При попытке поставить с репа софт, выдает вот такое

Err http://ubuntu.snacho.ru jaunty/universe linuxdcpp 1.0.2-1

404 Not Found

E: Failed to fetch http://ubuntu.snacho.ru/pool/universe/l/linuxdcpp/linuxdcpp_1.0.2-1_i386.deb: 404 Not Found

или на репе далеко не все зеркалируется?

Snacho, Y-m-d H:i

Т.к. репозиторий обновляется раз в один-два дня, список пакетов часто меняется. Поэтому советую раз в день получать список обновленных пакетов командой «sudo aptitude update»; или, если ты используешь Synaptic, нажатием кнопки Reload. Относительно этого пакета, ты можешь увидеть что в http://ubuntu.snacho.ru/pool/universe/l/linuxdcpp/ лежит только версия 1.0.3-1 т.е. теперь она - основная.

skat, Y-m-d H:i

Про обновление до 9.10

Ошибка при проверке подлинности некоторых пакетов

Не удалось проверить подлинность некоторых пакетов. Возможно, это кратковременная проблема с сетью, вам стоит попробовать снова позднее. Ниже приведен список пакетов, не прошедших проверку.

А aptitude update делал, вот только не помогает.

Tuma, Y-m-d H:i

У меня то же не хочет обновлять до 9.04 до 9.10. Пишет что недоступно зеркало «В процессе сканирования информации о Ваших репозиториях, не было найдено зеркало для обновления дистрибутива. Такое возможно в случае, если Вы используете внутреннее зеркало или информация о зеркалах устарела.»Хотя прописал оба репозитария.

skat, Y-m-d H:i

Там же в этом диалоге он предлагает переписать сорслист на кармик, ты соглашайся, и комп должен продолжить обновление

Tuma, Y-m-d H:i

*от 9.04 до 9.10

Snacho, Y-m-d H:i

Скажу честно. Я не знаю, как решить проблему с обновлением. Пробовал искать в гугле - не получилось. Создал две темы: http://forum.ubuntu.ru/index.php?topic=75099.0 http://ubuntuforums.org/showthread.php?p=8342198#post8342198

Результатов нету.

MAXA, Y-m-d H:i

А можно узнать, како именно убунтовский репозиторий зеркалируется?

Snacho, Y-m-d H:i

В связи с тем, что вопрос задается не в первый раз. Добавил информацию об источнике обновлений в раздел «Дополнительно»

Skat, Y-m-d H:i

А у вас зеркало слетело.

i_SweP, Y-m-d H:i

Во респект! Имхо с убунты всё линуксойдство и начинается. Правда дальше Дебиана оно у меня не ушло :)

Tuma, Y-m-d H:i

Зеркало так и не починили или это я пути криво прописал?

Александр, Y-m-d H:i

его хозяин наверное еухал и вырубил комп

Snacho, Y-m-d H:i

По непонятным причинам мой компьютер выключился, хотя я оставлял его включенным на время каникул. Как только я или мой сосед приедем в общежитие, зеркало возобновит работу.

Георге, Y-m-d H:i

заработало!!! аллиллуя !

Антон , Y-m-d H:i

интересно, сколько убунтоводов в сети?

dandelio, Y-m-d H:i

А как насчет обновления до lucid? Кто-нибудь уже перешел на новую ветку? =)

Snacho, Y-m-d H:i

Зеркало убунты временно отключено, предположительно до воскресенья(28.02.10).

Snacho, Y-m-d H:i

Всё снова заработало.

Thero, Y-m-d H:i

было-бы всё-таки неплохо добавить ключ, ибо иначе альтернэйт инсталл не работает с зеркалом… хотя может я что не так делаю.. в настройках зеркала ставлю ftp сервер ubuntu.snacho.ru путь к зеркалу / в остальных случаях ругается на невозможность скачать релиз… ЗЫ. ну хотя нефиг извращаться что бы получать такие проблеммы… ЗЫЫ наверное неважно…

Snacho, Y-m-d H:i

Прости. Я действительно готов сделать всё, что от меня зависит, чтобы всё заработало. Если ты сможешь подсказать, как восстановить работоспособность, я это сделаю. Выше в обсуждениях я писал о том, что мои попытки решить предыдущую проблему закончились неудачей, и на форумах поддержки помочь мне также не смогли :(

Snacho, Y-m-d H:i

Спасибо, почитал. Не совсем то, что нужно. Но в целом - кажется помогло :)

BAleks.ru, Y-m-d H:i

Не обновляется до lucid :( Вчера спросил на буржуйском убунтуфоруме: http://ubuntuforums.org/showthread.php?p=9138539 Пока никто не ответил..

Snacho, Y-m-d H:i

Обновил чистую убунту на виртуалке. Видимо проблема решена.

twee, Y-m-d H:i

а как от pulse audio избавиться? я видел много советов, но ни один не помог, звук вроде бы есть, но постоянно слышны какие-то шумы

BAleks.ru, Y-m-d H:i

http://www.google.ru/search?q=ubuntu+pulseaudio - вторая сссылка. учимся пользоваться дядей гуголом :)

twee, Y-m-d H:i

оно точно работает?

BAleks.ru, Y-m-d H:i

хз, все проверять как всегда надо лично у меня пашет все через pulse нормально проверь может не в пульсе дело, попробуй там через aplay что нибудь проиграть например, или mplayer -ao alsa (если он не через пульс попрет)

Dmitry, Y-m-d H:i

У меня както проблем небыло с обновлением до 10.04, только вот на примонтированном в это время внешнем жестком с ntfs чтото случилось с файловой системой. Это легко исправилось из под завиртуаленной winxp командой chkdsk \f.

panny, Y-m-d H:i

привет! вот я наверное глупость спрошу, но… а нет возможности настроить зеркало для OpenSuse?

panny, Y-m-d H:i

спасибо!

terry, Y-m-d H:i

Установил Ubuntu 10.10. Возникли проблемы с зеркалом обновлений. Пишет что система пакетов повреждена и не устанавливает обновления. С чем это может быть связано?

Snacho, Y-m-d H:i

Поставил на виртуалку 10.10, прописал репозиторий, как написано в инструкции, все обновления установились, новые программы тоже ставятся через синаптик(тестировал на wine). Проверь пожалуйста, правильно ли у тебя составлен файл /etc/apt/sources.list , если нет, воспользуйся рекомендациями данными выше. Также возможно, что ты попал на тот момент, когда зеркало обновлялось, попробуй перезагрузить список пакетов через synaptic или командой «sudo aptitude update». Если проблема сохраниться, напиши здесь или в dc на ^_ ^.

Acid, Y-m-d H:i

А как насчет зазеркалировать некоторые другие крупные\нужные репозитории? Например x swat update (свободные драйвера видео карт), Ubuntu Tweak, Chromium, Wine, Opera?

Snacho, Y-m-d H:i

У меня есть возможность обновляться только с mirror.yandex.ru . Насколько я вижу, там этих репозиториев нету.

Acid, Y-m-d H:i

Если ставить с netboot.iso (сетевая установка), то адрес указывать ubuntu.snacho.ru, а как указать папку?

Ваш комментарий. Вики-синтаксис разрешён:
 
linux/ubuntu.txt · Последние изменения: Y-m-d H:i — snacho
Наверх
CC Attribution-Noncommercial-Share Alike 3.0 Unported
Driven by DokuWiki Recent changes RSS feed Valid CSS Valid XHTML 1.0